mulc ヘルプ - 目次

mulc ヘルプ

mulcは入力した数値を10進・16進・2進など複数の表記形式で同時に表示し、そのまま計算もできる計算機です。

  • 数値の表示と入力
    • 数値バー
    • 色々な表示形式
    • モード
  • 計算機能
    • 基本的な計算
    • ビット演算
    • 数学関数
    • 三角関数
  • メニューコマンド
  • キー割り当て

動作環境、アンインストール方法、配付条件などについては同梱のドキュメント(ReadMe.txt)を御覧ください。

>次(N): 数値バー | mulcの説明に戻る


mulc ヘルプ - 数値バー

数値バー

バーの表示と消去

数値バーを表示するには次の方法があります。

  • 「バー」メニューから表示したい形式を選ぶ
  • ツールバーを出し、表示したい形式のボタンを押す

不要な数値バーを消すには、再びメニューまたはツールバーから同じ表示形式を選びます。

アクティブバー

数値バーをクリックすると、そのバーがアクティブになります。

Tabキー・Shift+Tabキー、↑・↓キーでもアクティブバーを切り替えることができます。

数字ボタン（0～9等）を押すと、現在アクティブな数値バーに数字が入力されます。

関連項目: 表示形式一覧、 メニューコマンド、キー操作

<前(P): 目次 | >次(N): 表示形式一覧 | ヘルプの目次(C) | mulcの説明に戻る


mulc ヘルプ - 表示形式一覧

表示形式一覧

mulcは以下の表示形式に対応しています。

  • DEC 10進数
  • HEX 16進数
  • BIN 2進数
  • OCT 8進数
  • DEG 60進数
  • KILO 1024進数
  • CHR 文字コード
  • TIME 日付/時刻
  • IP IPアドレス
  • FLT 浮動小数点
<前(P): 数値バー | >次(N): 10進数 | ヘルプの目次(C) | mulcの説明に戻る


mulc ヘルプ - 10進数

10進数(DEC)

表示形式

数値を10進数で表示します。最も基本的な表示形式です。

Realモードでは実数も表示できます。

数値の入力

0～9、小数点、+/- のボタンで数値を入力します。

モードとの関係

Realモードでは数値を実数として扱い、小数点以下まで表示します。

Signedモード、Reversedモードに対応しています。

関連項目: 数値バー、表示形式一覧、 モードについて

<前(P): 表示形式一覧 | >次(N): 16進・2進・8進数 | ヘルプの目次(C) | mulcの説明に戻る


mulc ヘルプ - 16進・2進・8進数

16進数(HEX)、 2進数(BIN)、 8進数(OCT)

表示形式

2の累乗を基数とした形式で数値を表示します。

HEXは 3F9B CA00 のように16進数で表示します。
BINは 0011 1011 1001 ... のように2進数で表示します。
OCTは 07346545000 のように8進数で表示します。

数値の入力

16進では0～9・A～F、 2進では0・1、 8進では0～7のボタンで数値を入力します。

モードとの関係

数値は常に符号なし整数として表示されます。

整数モードでは、数値を 0000 0001 のように0詰めして固定桁数で表示します。 実数モードの時には 1 のように0サプレスして表示します。

関連項目: 数値バー、表示形式一覧、 モードについて

<前(P): 10進数 | >次(N): 60進数 | ヘルプの目次(C) | mulcの説明に戻る


mulc ヘルプ - 60進数

60進数(DEG)

表示形式

数値を60進数として表示します。60進の各桁は「:」で区切られます。

たとえば、10進数の 4000 (=3600+360+40) は60進数では 1:06:40 となります。

［hms］モード

"hms" ボタンをオンにすると下位2ブロック（分・秒）までを60進数で表示し、3ブロック目からは10進数で表示します。

数値の入力

0～9 ボタンで数字を入力します。 ブロックごとの区切りは「:」ボタンで入力します。

モードとの関係

Realモードでは実数も表示・入力できます。ただし、小数点以下は 00:01:23.4567 のように10進表現になります。

Signedモード、Reversedモードに対応しています。

関連項目: 数値バー、表示形式一覧、 モードについて

<前(P): 16進・2進・8進数 | >次(N): 1024進数 | ヘルプの目次(C) | mulcの説明に戻る


mulc ヘルプ - 1024進数

1024進数(KILO)

表示形式

数値を K(=1024)、M(=1024*1024)、G(=1024*1024*1024) のように位取りして表示します。

たとえば、10進数の 1,000,000 (=1024*976+576) は1024進数では 976K+576 となります。

数値の入力

1024進バーがアクティブな場合、区切りボタン（:）が「KMG」に変わります。 区切りボタンを押すと「K」が入力されます。

区切りボタンを連続して押すと K→M→G のように位が上がっていきます。

モードとの関係

Realモードでは実数も入力できます。ただし、最下位のプレフィックスの付かない数字に限ります。 1K+2.34 のような表現はできますが、1.5G のような表現はできません。

Signedモード、Reversedモードに対応しています。

関連項目: 数値バー、表示形式一覧、 モードについて

<前(P): 60進数 | >次(N): 文字コード | ヘルプの目次(C) | mulcの説明に戻る


mulc ヘルプ - 文字コード

文字コード(CHR)

表示形式

ビットパターンを文字コードとして解釈し、対応する文字を表示します。

例えば、16進数で 4142 と入力すると、文字バーには "AB" と表示されます。

数値バー上のボタンで、文字コードの解釈を変えることができます。

  • A …… ASCII
  • S …… Shift-JIS
  • E …… EUC
  • J …… JIS

数値の入力

0～9、A～F のボタンを押すと、 対応する文字のASCIIコードが入力されます。

クリップボードからの貼り付けを使うと、任意の文字のコードを入力できます。

※貼り付けの際は常にShift-JISのコードで入力されます。

モードとの関係

Reversedモードに対応しています。

関連項目: 数値バー、表示形式一覧、 モードについて

<前(P): 1024進数 | >次(N): 日付/時刻 | ヘルプの目次(C) | mulcの説明に戻る


mulc ヘルプ - 日付/時刻

日付/時刻(TIME)

表示形式

日付/時刻を表示します。

数値バー上のボタンで、解釈方法を変更します。 また、数値を日付/時刻として解釈するか（時刻モード）、2つの日付・時刻の差分として解釈するか（時間差モード）を選択できます。

時刻モードでは 2001/09/09 01:46:40 のように、年月日+時分秒 を表示します。
時間差モードでは 11574d 01:46:40 のように、経過日数+時分秒 を表示します。

［t］ (time_t)

数値をCのtime_t型（1970年1月1日 0:00:00 からの経過秒数）と解釈します。

時間差(Diff)モードでは、数値を秒数として解釈して表示します。

［O］ (OLE DATE)

数値をOLEで使われるDATE型として解釈します（VCLのTDateTime型、VBのDATE型と同じ）。 DATE型では、数値の整数部分を日付（1899年12月30日からの経過日数）、小数部分を時刻（1.00=24H）と解釈します。

時間差(Diff)モードでは、数値を日数として解釈します。

なお、整数モードでは時刻を表現できないため、2001/09/09 のように日付部分しか表示されません。

［Diff］

押すたびに時刻モードと時間差モードが切り替わります。

時間差モードでは、日付部分は日数のみ表示され、年・月は入力できなくなります。

数値の入力

0～9のボタンで数字を入力します。

日付間(/)、日付と時刻の間（空白）、時刻間(:) の区切りはすべて区切りボタン(:)で入力します。

モードとの関係

Signedモード、Reversedモードに対応しています。

関連項目: 数値バー、表示形式一覧、 モードについて

<前(P): 文字コード | >次(N): IPアドレス | ヘルプの目次(C) | mulcの説明に戻る


mulc ヘルプ - IPアドレス

IPアドレス(IP)

表示形式

ビットパターンをIPアドレスと解釈し、IPアドレス形式で表示します。

数値の入力

0～9のボタンで数字を入力します。

バイト間の区切りは、小数点ボタン(.)または区切りボタン(:)で入力します。

モードとの関係

Byteモードでは1ブロック、Wordモードでは2ブロック分しか入力・表示できません。 Int64モード・Realモードでは、数値の下位32ビットだけが使われます。

Reversedモードに対応しています。

関連項目: 数値バー、表示形式一覧、 モードについて

<前(P): 日付/時刻 | >次(N): 浮動小数点 | ヘルプの目次(C) | mulcの説明に戻る


mulc ヘルプ - 浮動小数点

浮動小数点(FLT)

表示形式

ビットパターンをIEEE754の浮動小数点表現と解釈し、実数形式で表示します。

数値の入力

0～9、小数点(.)ボタンで数字を入力します。 指数記号は16進のEボタンで入力します。 また、Eの後の負号は+/-ボタン（ショートカットキー='_'）で入力します。

モードとの関係

Int64モードではDoubleフォーマット（64ビット）、それ以外のモードではSingleフォーマット（32ビット）と解釈します。

Reversedモードに対応しています。

関連項目: 数値バー、表示形式一覧、 モードについて

<前(P): IPアドレス | >次(N): モードについて | ヘルプの目次(C) | mulcの説明に戻る


mulc ヘルプ - モードについて

モードについて

整数モードと実数モード

  • Byte …… 数値を8ビット整数として扱います。
  • Word …… 数値を16ビット整数として扱います。
  • DWord …… 数値を32ビット整数として扱います。
  • Int64 …… 数値を64ビット整数として扱います。
  • Real …… 数値を実数として扱います。

Realモードの精度は80ビットで、有効数字は10進にして約19桁です。

Realモードで And, Or 等の整数演算を行う時には64ビット整数に変換されますが、有効数字の関係で下位ビットの数字が失われる場合があります。

Signedモード (Sgn)

Byte・Word・DWordモード選択時、符号なし／符号付きを切り替えます。

たとえば、16進数の FFFF(hex) は符号なし16ビットモードだと 65535(dec) になりますが、符号付き16ビットモードでは -1(dec) になります。

Reversedモード (Rev)

16進・8進・2進バーに入力された数値のバイトオーダーを反転して他のバーに表示します。

たとえば、16進数の 0001(hex) は通常 1(dec) ですが、Reversedモードでは 0100(hex) と解釈し、256(dec) と表示されます。

※SignedモードはInt64・Realモードでは無効です（常に符号付きになります）。 また、ReversedモードはByte・Realモードでは無効です。

<前(P): 浮動小数点 | >次(N): 基本的な計算 | ヘルプの目次(C) | mulcの説明に戻る


mulc ヘルプ - 基本的な計算

基本的な計算

+, -, *, / | 2数の加減乗除を行います。
Mod | 剰余（AをBで割った余り）を計算します。
+/- | 表示されている数値の正負を反転します。 符号なしモードの場合は、数値の2の補数を計算します。
= | 計算結果を表示します。
Ans | 直前に「=」で求めた計算結果を入力します。
AC | 入力値をゼロに戻し、計算の途中経過もリセットします。
CE | 入力値をゼロに戻します。計算の途中経過はリセットされません。
→ | アクティブバー上で、右端の1文字を消去します。

関連項目: ビット演算、数学関数、 三角関数、キーボード操作一覧

<前(P): モードについて | >次(N): ビット演算 | ヘルプの目次(C) | mulcの説明に戻る


mulc ヘルプ - ビット演算

ビット演算

And | ビットごとの論理積を計算します。
Or | ビットごとの論理和を計算します。
Xor | ビットごとの排他的論理和を計算します。
Not | 数値のビットを反転します。（0→1、1→0）
<<, >> | 数値を指定したビット数だけ左・右にシフトします。
<<n, >>n | 数値をボタンに表示されているビット数分だけ左・右にシフトします。 横のボタンで、シフトするビット数を変更できます（1, 2, 4, 8, 16 から選択）。
Rot | このボタンを押しておくと、シフトのかわりにローテートを行います。
Ari | このボタンを押しておくと、右シフトの時に論理シフトではなく算術シフトを行います。
Rev | 数値のバイトオーダーを反転します。例: FE10(hex) → 10FE
BRev | 数値のビット並びを反転します。例: 11010010(bin) → 01001011

※実数モード(Real)では Ari, Rot, Rev, BRev は使用できません。

関連項目: 基本的な計算、数学関数、 三角関数、キーボード操作一覧

<前(P): 基本的な計算 | >次(N): 数学関数 | ヘルプの目次(C) | mulcの説明に戻る


mulc ヘルプ - 数学関数

数学関数

Sqrt | 表示されている数値の平方根を計算します。
x^2 | 表示されている数値の自乗を計算します。
x^y | 数値の累乗を計算します。例: 8 x^y 3 → 512
Root | 数値の累乗根を計算します。例: 8 Root 3 → 2
e^x | eのx乗（xは表示されている数値）を計算します。例: 0 e^x → 2.71828182845904524
Ln | 表示されている数値の自然対数（eを底とする対数）を計算します。
Log | 表示されている数値の常用対数（10を底とする対数）を計算します。
Log2 | 表示されている数値の、2を底とする対数を計算します。
Trunc | 表示されている数値の整数部を取り出します。小数点以下は切り捨てられます。
Ceil | 表示されている数値の整数部を取り出します。小数点以下を切り上げます。
Frac | 表示されている数値の小数部を取り出します。
1/x | 表示されている数値の逆数を計算します。

※整数モード(Byte, Word, DWord, Int64)では Trunc, Ceil, Frac, 1/x は使用できません。

関連項目: 基本的な計算、ビット演算、 三角関数、キーボード操作一覧

<前(P): ビット演算 | >次(N): 三角関数 | ヘルプの目次(C) | mulcの説明に戻る


mulc ヘルプ - 三角関数

三角関数

sin, cos, tan | それぞれ、表示されている数値の正弦・余弦・正接を計算します。
asin, acos, atan | それぞれ、表示されている数値の逆正弦・逆余弦・逆正接を計算します。
Deg | sin, cos, tan では表示されている数値を度とみなして計算します。 asin, acos, atan では計算結果を度で表示します。
Rad | sin, cos, tan では表示されている数値をラジアンとみなして計算します。 asin, acos, atan では計算結果をラジアンで表示します。
Hyp | このボタンを押しておくと、双曲線関数(sinh, cosh, tanh)を計算します。
PI | 円周率πを入力します。

※整数モード(Byte, Word, DWord, Int64)では三角関数の機能は使えません。

関連項目: 基本的な計算、ビット演算、 数学関数、キーボード操作一覧

<前(P): 数学関数 | >次(N): メニューコマンド一覧 | ヘルプの目次(C) | mulcの説明に戻る


mulc ヘルプ - メニューコマンド一覧

メニューコマンド一覧

「編集」メニュー

コピー | アクティブバーに表示されている内容をコピーします。
コピー（区切り付き） | アクティブバーに表示されている内容を、桁区切りも含めてそのままコピーします。
貼り付け | クリップボードの文字列をアクティブバーに入力します。
終了 | mulcを終了します。

「バー」メニュー

選択したバーの表示・非表示を切り替えます。 バーの種類については表示形式一覧を参照してください。

「表示」メニュー

桁区切り | チェックすると、10進数・16進数・2進数を桁区切り付きで表示します。 チェックを外すと桁区切りがなくなります。
状態表示 | チェックすると、数値バー上に現在の状態（Signed、Revなど）が表示されます。 チェックを外すと状態表示が消えます。
ツールバー | ツールバーの表示・非表示を切り替えます。
メニューバー | メニューバーを消去します。※
プッシュボタン | プッシュボタン部分の表示・非表示を切り替えます。
常に手前に表示 | チェックすると、他のアプリケーションより手前に表示されます。
演算メニュー | 演算メニューを表示します。
モードメニュー | モードメニューを表示します。
フォント | 数値バーのフォントを変更します。
本体の色 | 本体の背景色を変更します。

※メニューバーを再び表示するには： mulc本体の何もない場所を右クリックすると表示メニューが現れます。その中から「メニューバー」を選んでください。

「ヘルプ」メニュー

トピックの検索 | このヘルプを表示します。
バージョン情報 | mulcのバージョン情報を表示します。

関連項目: キーボード操作一覧

<前(P): 三角関数 | >次(N): キーボード操作一覧 | ヘルプの目次(C) | mulcの説明に戻る


mulc ヘルプ - キーボード操作一覧

キーボード操作一覧

バー操作

キー | 動作
↑, ↓ | アクティブバー切り替え
Tab, Shift+Tab | アクティブバー切り替え
Alt+(数値バーの先頭文字) | 対応するバーをアクティブにする
←, → | 文字コード・ 時刻バーのエンコード切り替え
Ctrl+Space | 60進数バーのhmsモード、 時刻バーのDiffモード切り替え
Ctrl+F4 | アクティブバーを消去する

数値入力

キー | 対応するボタン | 動作
0～9, A～F | 0～9, A～F | 数字を入力
.（ピリオド） | . | 小数点を入力
:（コロン） | :, /:, KMG | 60進数・ 1024進数・日付/時刻の区切りを入力
BackSpace | → | 1文字消去
Del | CE | 数値を消去
Esc | AC | 数値消去+計算状態リセット

計算機能

キー | 対応するボタン | 動作
= | = | 計算結果表示
? | Ans | 直前の計算結果を入力
+ | + | 加算
- | - | 減算
* | * | 乗算
/ | / | 除算
% | Mod | 剰余
_（アンダーバー） | +/- | 符号反転（2の補数）
& | And | 論理積
| | Or | 論理和
^ | Xor | 排他的論理和
~ | Not | ビット反転（1の補数）
< | << | 左シフト
> | >> | 右シフト
{ | <<n | 左クイックシフト
} | >>n | 右クイックシフト
;（セミコロン） | ▼ | クイックシフトのビット数選択
v | Rev | バイトオーダー反転
Shift+v | BRev | ビット順反転
@ | Sqrt | 平方根
` (Shift+@) | x^2 | 自乗
w | x^y | 累乗
t | Root | 累乗根
x | e^x | eの累乗
Shift+x |  | 2の累乗
y |  | 10の累乗
n | Ln | 自然対数
l | Log | 常用対数
Shift+l | Log2 | 2を底とする対数
g |  | 任意の底の対数
i | Trunc | 切り捨て
j | Ceil | 切り上げ
k |  | 四捨五入
# | Frac | 小数部取り出し
\ | 1/x | 逆数
! |  | 階乗
Shift+i | sin | 正弦
Shift+o | cos | 余弦
Shift+t | tan | 正接
Shift+p | PI | 円周率を入力
q |  | 演算メニュー表示
Shift+q |  | 演算メニュー表示（日本語）

モード切り替え

キー | 対応するボタン | 動作
Ctrl+B | Byte | 8ビット整数
Ctrl+W | Word | 16ビット整数
Ctrl+D | DWord | 32ビット整数
Ctrl+Q | Int64 | 64ビット整数
Ctrl+R | Real | 実数
Ctrl+S | Sgn | 符号なし・符号付き切り替え
Ctrl+E | Rev | バイトオーダー変換の有無
Ctrl+A | Ari | 論理シフト・算術シフト切り替え
Ctrl+T | Rot | シフト・ローテート切り替え
Ctrl+H | Hyp | 双曲線関数
m |  | モードメニュー表示

関連項目: メニューコマンド一覧

<前(P): メニューコマンド一覧 | >次(N): 演算メニュー | ヘルプの目次(C) | mulcの説明に戻る


mulc ヘルプ - 演算メニュー

演算メニュー

ビット演算・数学関数・ 三角関数に属する演算機能を一覧表示します。 タブ切り替えなしで演算を実行することができます。 各機能に割り当てられたショートカットキーも確認できます。

qキーで演算メニュー、Shift+qキーで日本語の演算メニューを表示します。

<前(P): キーボード操作一覧 | >次(N): モードメニュー | ヘルプの目次(C) | mulcの説明に戻る


mulc ヘルプ - モードメニュー

モードメニュー

mキーを押すとモード切り替え機能をメニュー表示します。 各機能に割り当てられたショートカットキーも確認できます。

<前(P): 演算メニュー | ヘルプの目次(C) | mulcの説明に戻る