monosash ヘルプ - 目次

monosash ヘルプ

monosashは、縦と横が組になった定規です。 ウィンドウなどの近くに持って行ってサイズを測ってください。

目盛は、デフォルトではピクセル単位になっています。

目次

基本的な使い方

  • 定規を動かす
    左上の部分をつかんでドラッグ
  • 長さを変える
    定規の端をつまんでドラッグ
  • 測る
    定規の上でマウスボタンを押してからドラッグ
  • 終了させる
    左上の部分を右クリックしてメニューを出し、「終了」を選択
  • ウィンドウの下に隠れないようにする
    メニューから「常に前面に表示」を選択

その他の使い方

  • 2点間の長さを測る
    Shiftキーを押しながらドラッグ
  • 目盛をずらす
    Ctrlキーを押してドラッグ、ダブルクリックで元に戻す
  • スケールを変える
    Altキーを押しながらドラッグ、ダブルクリックで元に戻す
  • マウスカーソルを固定する
    ドラッグ中にTabキー
monosashの説明に戻る


monosash ヘルプ - 定規を動かす

定規を動かす

定規の左上の部分でマウスの左ボタンを押し、そのままドラッグして動かします。

※注意: 画面のプロパティで「ドラッグ中にウィンドウの内容を表示する」を無効にしている場合、 ドラッグ中は四角い枠だけが表示されます。

>次(N): 長さを変える | ヘルプの目次(C) | monosashの説明に戻る


monosash ヘルプ - 長さを変える

長さを変える

定規の端にマウスカーソルを近づけると、カーソルの形が変わります。 この状態でマウスボタンを押してドラッグすると長さを変えられます。

<前(P): 定規を動かす | >次(N): 測る | ヘルプの目次(C) | monosashの説明に戻る


monosash ヘルプ - メニュー

メニュー

定規の左上の部分でマウスの右ボタンを押すと、メニューが表示されます。

メニューコマンドの意味は次のとおりです。

常に前面に表示 | 定規が他のウィンドウの下に隠れないようにします。 もう一度選択すると元に戻ります。
透明 | 定規を半透明にします。 もう一度選択すると元に戻ります。 （半透明機能はWindows2000以上で有効です。)
色の変更 定規の色を変更します。
選択すると「色の設定」ダイアログが表示されるので、色を選んでOKボタンを押してください。
今の状態を保存 今の状態を保存し、次にmonosashを起動した時に同じ状態で表示されるようにします。
保存されるのは以下の項目です。
  • 常に前面に表示
  • 透明
  • 定規の色
  • 目盛の位置
  • 定規のスケール
ヘルプ | WinHelp版のヘルプが表示されます。
バージョン情報 | バージョン情報画面を表示します。
終了 | プログラムを終了させます。
<前(P): 測る | >次(N): 2点間の長さを測る | ヘルプの目次(C) | monosashの説明に戻る


monosash ヘルプ - 測る

測る

定規の上でマウスの左ボタンをクリックすると、その場所に目盛の数字が表示されます。 そのままドラッグすると、数字も一緒に動きます。

マウスボタンを離すと元に戻ります。

特殊な機能

他のキーを押しながらドラッグすることで、特殊な機能を使うことができます。

Shiftキー
ドラッグした範囲の長さを表示
Ctrlキー
目盛の位置をずらす
Altキー
定規のスケールを変える
Tabキー
マウスカーソルを固定する
<前(P): 長さを変える | >次(N): メニュー | ヘルプの目次(C) | monosashの説明に戻る


monosash ヘルプ - 2点間の長さを測る

2点間の長さを測る

  1. 定規の上でマウスボタンを押し、そのまま測りたい物の一方の端までドラッグしていきます。
  2. Shiftキーを押します。
  3. Shiftキーを押したまま、もう一方の端までドラッグします。 定規の上に、その範囲の長さが表示されます。
<前(P): メニュー | >次(N): 目盛をずらす | ヘルプの目次(C) | monosashの説明に戻る


monosash ヘルプ - 目盛をずらす

目盛をずらす

  1. Ctrlキーを押しながら、定規の上でマウスボタンを押します。 （この時、マウスカーソルが「0」の位置に移動します。）
  2. そのままドラッグすると、目盛の「0」がカーソルと一緒に動き、それにつれて全体の目盛がずれます。
  3. マウスボタンを離すと、その位置で目盛が固定されます。

※定規のどこでもいいのでダブルクリックすると、最初の状態（一番端が0）に戻ります。

<前(P): 2点間の長さを測る | >次(N): スケールを変える | ヘルプの目次(C) | monosashの説明に戻る


monosash ヘルプ - スケールを変える

スケールを変える

  1. 定規の上でマウスボタンを押し、適当な位置までドラッグします。
  2. Altキーを押します。
  3. Altキーを押したままドラッグすると、それにつれて目盛が伸縮します。 （縦・横両方の目盛が同じ比率で伸び縮みします。）
  4. Altキーかマウスボタンを離すと、その位置で目盛が固定されます。

※定規のどこでもいいのでダブルクリックすると、デフォルトの比率（1目盛が1ピクセル）に戻ります。

<前(P): 目盛をずらす | >次(N): マウスカーソルを固定する | ヘルプの目次(C) | monosashの説明に戻る


monosash ヘルプ - マウスカーソルを固定する

マウスカーソルを固定する

  1. 定規の上でマウスボタンを押し、適当な位置までドラッグします。
  2. Tabキーを押すと、マウスカーソルが固定されます。
    • 横定規の場合は、マウスの横の位置が固定されて、上下にしか動かなくなります。
    • 縦定規の場合は、マウスの縦の位置が固定されて、左右にしか動かなくなります。
  3. Tabキーを離すと、また自由に動けるようになります。
<前(P): スケールを変える | ヘルプの目次(C) | monosashの説明に戻る