ConcatPrint ヘルプ - 目次

ConcatPrint ヘルプ

ConcatHelpは、複数のテキストファイルを一つにつなげて印刷するツールです。

  • はじめに
  • とりあえず使ってみる
  • 機能説明
    • ファイル選択
    • メニューコマンド
    • 印刷設定
    • プレビュー機能
    • 環境設定
    • コマンドライン
  • よくありそうな質問と回答
>次(N): はじめに | ConcatPrintの説明に戻る


ConcatPrint ヘルプ - はじめに

はじめに

アンインストールについて

以下のファイルを削除してください。 （専用のディレクトリを作っている場合はディレクトリごと削除すればOKです）

  • アーカイブに含まれるファイル
    • ConcatPrint.exe
    • ConcatPrint.hlp
    • ConcatPrint.cnt
    • jcode.dll
    • ReadMe.txt
  • 後から作られるファイル
    • ConcatPrint.ini
    • ConcatPrint.gid

jcode.dllについて

jcode.dll は vice 氏によって作成された、文字コードの相互変換を行うライブラリです。 Shift JIS 以外の文字コード(EUC, JIS)で書かれたファイルを印刷するために必要です。 文字コードの変換機能を使わない場合は、インストールする必要はありません。

同梱されているDLLのバージョンは 環境設定画面の「文字コード変換」で確認できます。

最新版のDLLは、以下の場所から入手できます。

  • 作者ページ
  • Vectorライブラリ
<前(P): 目次 | >次(N): とりあえず使ってみる | ヘルプの目次(C) | ConcatPrintの説明に戻る


ConcatPrint ヘルプ - とりあえず使ってみる その1

とりあえず使ってみる

その1 ファイルを選ぶ

  1. 左のディレクトリツリーから、印刷したいファイルのあるディレクトリを選択します。

    →複数ディレクトリのファイルを印刷するには

  2. 「フィルタ」で印刷するファイルの種類を指定します。

    →フィルタの指定方法

    ワイルドカードを使って *.c のように指定します。セミコロンで区切って複数のフィルタを指定できます。

  3. 印刷したくないファイルがあったら、チェックボックスのチェックを外しておきます。

  4. ファイルを印刷したい順番に並べ替えます。

    →ファイルの並べ替え

<前(P): はじめに | >次(N): その2 印刷方法を設定する | ヘルプの目次(C) | ConcatPrintの説明に戻る


ConcatPrint ヘルプ - とりあえず使ってみる その2

とりあえず使ってみる

その2 印刷方法を設定する

  1. ツールバーの「設定」ボタンを押してください。印刷設定ダイアログが表示されます。

  2. 一番重要な設定、ファイルの区切りをどうするかです。 「改ページする」を選ぶと、ファイルごとに改ページします。それ以外はファイルを一つにつなげて印刷します。

    プログラムソースの印刷の場合、体裁のところの「タブの幅」もチェックしておいた方が良いでしょう。

  3. 設定が終わったら「OK」ボタンを押してダイアログを閉じます。

<前(P): その1 ファイルを選ぶ | >次(N): その3 印刷する | ヘルプの目次(C) | ConcatPrintの説明に戻る


ConcatPrint ヘルプ - とりあえず使ってみる その3

とりあえず使ってみる

その3 印刷する

  1. ツールバーの「印刷」ボタンを押してください。印刷ダイアログが表示されます。

  2. 用紙、印刷する範囲、部数などを選択してから「OK」を押してください。

  3. 印刷経過ダイアログが表示され、印刷が始まります。

    ※ 印刷するページ数が少ない場合、この画面は一瞬しか表示されない場合があります。

印刷の中断

印刷をとりやめたい場合は、経過表示画面の「中断」ボタンを押してください。

すでにプリンタが印刷を開始している場合、タスクトレイにプリンタのアイコンが表示されているので ダブルクリックして印刷ステータスウィンドウを開き、印刷を停止させてください。（操作方法はプリンタによって異ります。）

「とりあえず使ってみる」はこれで終わりです。より詳しい使い方は「機能説明」の項を参照してください。

<前(P): その2 印刷方法を設定する | >次(N): ファイル選択画面 | ヘルプの目次(C) | ConcatPrintの説明に戻る


ConcatPrint ヘルプ - ファイル選択画面

ファイル選択画面

ConcatPrintのメインウィンドウです。この画面で印刷対象のファイルを選択します。印刷の実行、書式設定などもこの画面から呼び出します。

説明を見たい場所をクリックしてください。

ディレクトリリスト ファイル一覧 ドライブリスト ネットワークドライブ フィルタ 下位ディレクトリも含める ツールボタン

ディレクトリリスト

ファイルのあるディレクトリを選択します。 クリックまたは上下キーでディレクトリを選び、ダブルクリックまたはEnterキーでそのディレクトリに移動します。 選択したディレクトリにあるファイルがファイル一覧に表示されます。

ファイル一覧

選択したディレクトリ内のファイルが一覧表示されます。

ここでチェックボックスにチェックを付けたファイルが印刷対象になります。 チェックボックス部分をクリックするか、スペースキーを押すとチェックボックスが切り替わります。

この画面でファイルをドラッグして順番を変えることもできます。

ドライブリスト

ドライブを選択します。 ここで選択したドライブの中のディレクトリがディレクトリリストに表示されます。

ネットワークドライブ

「ネットワークドライブの割り当て」ダイアログが表示されます。 ネットワークのパスを入力してOKを押すとドライブリストに追加され、 通常のドライブと同じように操作できるようになります。

フィルタ

ファイル一覧に、特定の名前のファイルだけを表示するようにします。 「フィルタ」ボックスのリストからファイルの種類を選択するか、直接ファイルの種類を入力します。

※ キーボードからファイルの種類を入力した場合は、横の「表示」ボタンを押すと反映されます。

ファイルの種類は、「*.c」のようにワイルドカードで指定します。 ファイルの種類を複数指定するには、「*.c; *.h」のようにセミコロンで区切ります。 「*.*」と入力するとすべてのファイルを表示します。

関連項目: 環境設定-フィルタリスト

下位ディレクトリも含める

チェックを付けると、選択したディレクトリ以下にあるすべてのファイルをファイル一覧に表示します。

ツールボタン

それぞれファイルメニュー内の「印刷」「プレビュー」「設定」と同じ機能です。

関連項目

  • 複数ディレクトリのファイルを印刷する
  • ファイルの並べ替え
  • メニューコマンド
<前(P): とりあえず使ってみる | >次(N): 複数ディレクトリのファイルを印刷する | ヘルプの目次(C) | ConcatPrintの説明に戻る


ConcatPrint ヘルプ - 複数ディレクトリのファイルを印刷する

ファイル選択画面

複数ディレクトリのファイルを印刷する

複数のディレクトリにまたがるファイルを印刷するには、 それらの上位ディレクトリを選んでから「下位ディレクトリも含める」にチェックを付けます。

エクスプローラなどからファイルをドラッグ＆ドロップで追加することもできます。 ※この方法で追加したファイルは、別のディレクトリを選択したり「フィルタ」を変更すると一覧から消えてしまいます。

<前(P): ファイル選択画面 | >次(N): ファイルの並べ替え | ヘルプの目次(C) | ConcatPrintの説明に戻る


ConcatPrint ヘルプ - ファイルの並べ替え

ファイル選択画面

ファイルの並べ替え

ファイルはファイル一覧の並び順に印刷されます。 ファイルの順番を変えるには、次の方法があります。

  • 「並べ替え」メニューのコマンドを使う

  • ファイル一覧の列ヘッダをクリックする （表示メニューで詳細表示モードに設定している場合）

  • ファイルをドラッグ＆ドロップで並べ替える

<前(P): 複数ディレクトリのファイルを印刷する | >次(N): メニューコマンド | ヘルプの目次(C) | ConcatPrintの説明に戻る


ConcatPrint ヘルプ - メニューコマンド

メニューコマンド

  • 「ファイル」メニュー
    • 印刷
    • プレビュー
    • 設定
    • 選択ファイルを印刷
    • 選択ファイルをプレビュー
    • 環境設定
    • 終了
  • 「編集」メニュー
    • すべて選択
    • 選択を反転
    • チェックを付ける
    • チェックを外す
    • チェック反転
    • 上へ移動
    • 下へ移動
    • プロパティ
  • 「並べ替え」メニュー
    • 名前順
    • サイズ順
    • ファイルの種類順
    • 更新日時順
    • 場所順
    • 場所でグループ化
    • 昇順
    • 降順
  • 「表示」メニュー
    • アイコン表示
    • 一覧表示
    • 詳細表示
    • 最新の情報に更新
  • 「ヘルプ」メニュー
    • トピックの検索
    • バージョン情報
<前(P): ファイルの並べ替え | >次(N): 「ファイル」メニュー | ヘルプの目次(C) | ConcatPrintの説明に戻る


ConcatPrint ヘルプ - 「ファイル」メニュー

「ファイル」メニューのコマンド

印刷

印刷を開始します。 ファイル一覧でチェックの付いているファイルが印刷対象になります。

プレビュー

印刷した時のイメージを画面で確認できます。 ファイル一覧でチェックの付いているファイルが印刷対象になります。

操作方法は「プレビュー画面」を参照してください。

設定

印刷設定画面を表示します。

選択ファイルを印刷

ファイル一覧で選択状態（反転表示）になっているファイルだけを対象にして印刷します。

選択ファイルをプレビュー

ファイル一覧で選択状態（反転表示）になっているファイルだけを対象にしてプレビューを表示します。

環境設定

環境設定画面を表示します。

終了

ConcatPrintを終了します。

↑メニューコマンド一覧へ

<前(P): メニューコマンド | >次(N): 「編集」メニュー | ヘルプの目次(C) | ConcatPrintの説明に戻る


ConcatPrint ヘルプ - 「編集」メニュー

「編集」メニューのコマンド

すべて選択

ファイル一覧のファイルをすべて選択状態（反転表示）にします。

選択を反転

ファイル一覧の選択状態（反転表示）を切り換えます。 コマンドを実行すると、選択されたファイルが通常状態になり、逆に通常状態のファイルは選択状態になります。

ファイルが一つ選択されている状態と…… ⇔ 一つ除いてすべてのファイルが選択されている状態を切り替えられます

チェックを付ける

選択状態（反転表示）になっているファイルにチェックを付けて印刷対象にします。

チェックを外す

選択状態（反転表示）になっているファイルからチェックを外し、印刷対象から除外します。

チェック反転

選択状態（反転表示）になっているファイルそれぞれについて、チェックボックスのオン・オフを反転します。

上へ移動

ファイル一覧で選択状態（反転表示）になっているファイルを、一つずつ上に移動します。

下へ移動

ファイル一覧で選択状態（反転表示）になっているファイルを、一つずつ下に移動します。

※ドラッグ＆ドロップでもファイルの順番を変えることができます。→ファイルの並べ替え

プロパティ

選択したファイルのプロパティを表示します。

↑メニューコマンド一覧へ

<前(P): 「ファイル」メニュー | >次(N): 「並べ替え」メニュー | ヘルプの目次(C) | ConcatPrintの説明に戻る


ConcatPrint ヘルプ - 「並べ替え」メニュー

「並べ替え」メニューのコマンド

名前順・サイズ順・ファイルの種類順・更新日時順・場所順

それぞれ選択した基準でファイルを並べ替えます。

名前順
ファイル名（ABC順）
サイズ順
ファイルサイズ（小さい順）
種類順
「ファイルの種類」の表記（ABC順）
更新日時
ファイルの更新日時（古い順）
場所順
ファイルのあるディレクトリ（ABC順）

※ 上は「昇順」を選んだ場合の順番です。「降順」の場合は順番が逆になります。

場所でグループ化

チェックを付けておくと、ファイルを並べ替える際に同じディレクトリのファイルをグループにまとめます。

グループ化しない場合
ディレクトリに関係なく、名前などの順番に並びます 		グループ化した場合
同じディレクトリ内のファイルが一箇所にまとまります

昇順・降順

ファイルを並べる順番を指定します。 「昇順」は小さい方から大きい方へ、「降順」はその逆になります。

↑メニューコマンド一覧へ

<前(P): 「編集」メニュー | >次(N): 「表示」メニュー | ヘルプの目次(C) | ConcatPrintの説明に戻る


ConcatPrint ヘルプ - 「表示」メニュー

「表示」メニューのコマンド

アイコン・一覧・詳細表示

ファイル一覧の表示方法を指定します。

アイコン
ファイルを大きいアイコンで表示します。
一覧
ファイル名だけを一覧表示します。
詳細
ファイル名に加えて、サイズ、更新日時などの詳細情報を表示します。

最新の情報に更新

ドライブ・ディレクトリ・ファイルの一覧を、最新の情報に合わせて更新します。

↑メニューコマンド一覧へ

<前(P): 「並べ替え」メニュー | >次(N): 「ヘルプ」メニュー | ヘルプの目次(C) | ConcatPrintの説明に戻る


ConcatPrint ヘルプ - 「ヘルプ」メニュー

「ヘルプ」メニューのコマンド

トピックの検索

WinHelp版のヘルプを開きます。

バージョン情報

ConcatPrintのバージョン情報を表示します。

なお、同梱されているjcode.dllのバージョンは[環境設定]-[文字コード変換]の画面で確認できます。

↑メニューコマンド一覧へ

<前(P): 「表示」メニュー | >次(N): 印刷設定画面 | ヘルプの目次(C) | ConcatPrintの説明に戻る


ConcatPrint ヘルプ - 印刷設定画面

印刷設定画面

印刷方法や書式の設定を行う画面です。

「印刷方法」タブ 「余白」タブ 「体裁」タブ 「フォント」タブ 「OK」ボタン 「キャンセル」ボタン 「プリンタの設定」ボタン 「プレビュー」ボタン
  • 「印刷方法」タブ
  • 「余白」タブ
  • 「体裁」タブ
  • 「フォント」タブ

「OK」ボタン

設定内容を保存して、「印刷設定」ダイアログを閉じます。

「キャンセル」ボタン

設定を保存せずに「印刷の設定」ダイアログを閉じます。

「プリンタの設定」ボタン

「プリンタの設定」ダイアログを表示します。 この画面で、プリンタの選択、用紙の変更などを行います。

「プレビュー」ボタン

「印刷設定」ダイアログの現在の設定内容でプレビューを表示します。

※ プレビューにはファイル選択画面でチェックを付けたファイルが使われます。 ファイルがない場合には「プレビュー」ボタンは使えません。

<前(P): 「ヘルプ」メニュー | >次(N): 「印刷方法」タブ | ヘルプの目次(C) | ConcatPrintの説明に戻る


ConcatPrint ヘルプ - 印刷設定画面 - 「印刷方法」タブ

印刷設定画面 - 「印刷方法」タブ

ファイルの区切り 先頭にファイル名を印刷する ファイルごとにカウントする

ファイルの区切り

ファイル同士をどのように区切るかを設定します。

改ページする
ファイルとファイルの間でページを区切ります。
1行空ける
同じページに印刷します。ファイルとファイルの間に1行分スペースを入れます。
2行空ける
同じページに印刷します。ファイルとファイルの間に2行分スペースを入れます。
区切りなし
ファイルとファイルの間を切れ目なしに印刷します。
実線で区切る
同じページに印刷します。ファイルとファイルの間に区切り線を入れます。
点線で区切る
同じページに印刷します。ファイルとファイルの間に点線で区切り線を入れます。

先頭にファイル名を印刷する

チェックを付けると、各ファイルの先頭にファイル名を枠で囲んで印刷します。

ファイルごとにカウントする

チェックを付けた場合、印刷するファイルが変わるたびに、ページ番号を1にリセットします。 また、総ページ数もファイルごとに別々にカウントされます。

チェックを外した場合、ページ番号は1から順番に付きます。また、総ページ数は全ファイルの合計ページ数になります。

関連項目: 「体裁」タブ（ページ番号を印刷する、総ページ数を印刷する）

<前(P): 印刷設定画面 | >次(N): 「余白」タブ | ヘルプの目次(C) | ConcatPrintの説明に戻る


ConcatPrint ヘルプ - 印刷設定画面 - 「余白」タブ

印刷設定画面 - 「余白」タブ

各部の余白の指定

「余白」で用紙と本文の間の余白、 「本文からの距離」でヘッダ・フッタと本文の距離を設定します。

※ヘッダやフッタは、用紙の余白領域に印刷されます。 余白が狭い場合、ヘッダやフッタが印刷できるように余白を調整するため、本文領域が狭くなることがあります。

ヘッダとフッタ

用紙の上の余白に印刷される内容をヘッダ、下の余白に印刷される内容をフッタと呼びます。

ConcatPrintでは、ファイル名と日付をヘッダに、ページ番号・総ページ数をフッタに印刷します。 これらの要素を印刷しない場合、ヘッダ・フッタは付きません。

単位について

余白の指定では以下の単位が指定できます。

mm
ミリメートル
cm
センチメートル （1cm = 10mm)
in
インチ (1in = 2.54cm)
pt
ポイント (1pt = 1/72in)
<前(P): 「印刷方法」タブ | >次(N): 「体裁」タブ | ヘルプの目次(C) | ConcatPrintの説明に戻る


ConcatPrint ヘルプ - 印刷設定画面 - 「体裁」タブ

印刷設定画面 - 「体裁」タブ

タブの幅 行間の空き 行の折り返し 英単語の途中で改行しない 日本語の禁則処理を行う ^Lで改ページする ページ番号を印刷する 総ページ数を印刷する 行番号を印刷する ファイル名を印刷する 日付を印刷する

タブの幅

印刷の際、タブを空白何個分で置き換えるかを指定します。 2, 4, 8 のうちから選択できます。

行間の空き

読みやすいように行と行の間を空けることができます。 空ける量を、フォントサイズに対する%で指定します。

0%: 行間は空きません
50%: 行間が約半分空きます。
100%: 行間が約1行空きます。

行の折り返し

1行が長すぎて左右の余白の間に収まらない場合、折り返して印刷することができます。

左寄せ
折り返した行を左の余白に寄せます。
右寄せ
折り返した行を右の余白に寄せます。
前の行と揃える
先頭が揃うように折り返します。
折り返さない
折り返しをしません。余白にはみ出した文字は印刷されません。

英単語の途中で改行しない

行を折り返す際、英単語や数字の途中で切らないようにします。

チェックなしの場合: 単語が途中で切れます。
チェックありの場合: 単語が切れないよう、手前で改行されます。

日本語の禁則処理を行う

行を折り返す際、句読点（、。）や鉤括弧（「」）などが行の先頭にこないようにします。

^Lで改ページする

改ページの制御記号（文字コード12。^L, Ctrl-L, FF (Form Feed) とも表記されます） で実際に改ページします。

ページ番号を印刷する

各ページのフッタにページ番号を印刷します。

総ページ数を印刷する

ページ番号の後に「1 / 99」のように総ページ数を印刷します。

行番号を印刷する

各行の先頭に行番号を印刷します。

ファイル名を印刷する

各ページのヘッダにファイル名を印刷します。

※ 1ページに複数のファイルがある場合、ページの先頭にきたファイルの名前が印刷されます。

日付を印刷する

各ページのヘッダに、印刷した日付・時刻を印刷します。

<前(P): 「余白」タブ | >次(N): 「フォント」タブ | ヘルプの目次(C) | ConcatPrintの説明に戻る


ConcatPrint ヘルプ - 印刷設定画面 - 「フォント」タブ

印刷設定画面 - 「フォント」タブ

現在設定されているフォントが一覧表示されます。

本文
本文の印刷に使われるフォント
行番号
行番号の印刷に使われるフォント
ヘッダ
ヘッダ（ファイル名と日付の部分）に使われるフォント
フッタ
フッタ（ページ番号の部分）に使われるフォント

リストから変更したい場所を選んで「変更」ボタンを押すと、フォントを変更できます。

<前(P): 「体裁」タブ | >次(N): プレビュー画面 | ヘルプの目次(C) | ConcatPrintの説明に戻る


ConcatPrint ヘルプ - プレビュー画面

プレビュー画面

印刷イメージを確認する画面です。

  • ページ移動
  • ズーム
  • キー操作
<前(P): 「フォント」タブ | >次(N): ページ移動 | ヘルプの目次(C) | ConcatPrintの説明に戻る


ConcatPrint ヘルプ - プレビュー画面のページ移動

プレビュー画面のページ移動

ツールバー

ツールバーの前ページ・次ページボタンを押すと、1ページ単位で前後に移動します。

また、ページ番号ボックスにページ番号を入力してEnterキーを押すと、直接そのページに移動します。

メニュー

ツールバーの「ページ」メニューでページの移動ができます。

前のページ
1ページ前に移動します。
次のページ
1ページ後に移動します。
先頭ページ
1ページ目に移動します。
最終ページ
最後のページに移動します。
ページ番号指定
ページ番号ボックスにフォーカスが移動します。
ファイル指定
ファイル一覧を表示し、指定したファイルの先頭に移動します。
<前(P): プレビュー画面 | >次(N): ズーム | ヘルプの目次(C) | ConcatPrintの説明に戻る


ConcatPrint ヘルプ - プレビュー画面のズーム

プレビュー画面のズーム

ツールバーの「ズーム」メニューで、表示倍率を変更できます。

100%
通常のサイズで表示します。
200%
2倍に拡大して表示します。
50%
半分に縮小して表示します。
幅に合わせる
紙面の幅がウィンドウと一致するように表示します。
高さに合わせる
紙面の高さがウィンドウと一致するように表示します。
全体を表示
紙面全体がウィンドウに収まるように表示します。
10%拡大
少し拡大します。
10%縮小
少し縮小します。
倍率指定
任意の倍率を指定できます。
<前(P): ページ移動 | >次(N): キー操作 | ヘルプの目次(C) | ConcatPrintの説明に戻る


ConcatPrint ヘルプ - プレビュー画面のキー操作

プレビュー画面のキー操作

キー | 動作
↓ | 下スクロール（小）
↑ | 上スクロール（小）
Ctrl+↓ PgDn スペースキー | 下スクロール（大）
Ctrl+↑ PgUp Ctrl+スペースキー BackSpace | 上スクロール（大）
← | 左スクロール（小）
→ | 右スクロール（小）
Ctrl+← Ctrl+PgUp | 左スクロール（大）
Ctrl+→ Ctrl+PgDn | 右スクロール（大）
Home | ページの先頭へ
End | ページの末尾へ
Ctrl+Home | 1ページ目の先頭へ
Ctrl+End | 最終ページの末尾へ
Alt+← | 前のページへ
Alt+→ | 次のページへ
Alt+Home | 先頭ページへ
Alt+End | 最終ページへ
Esc | プレビュー画面を閉じる

※ ページの末尾を表示している時に下スクロールすると、次のページの先頭に移動します。 同様に、ページの先頭から上にスクロールすると、前ページの末尾に移動します。

<前(P): ズーム | >次(N): 環境設定画面 | ヘルプの目次(C) | ConcatPrintの説明に戻る


ConcatPrint ヘルプ - 環境設定画面

環境設定画面

ConcatPrintの環境設定を行う画面です。

「フィルタ」タブ 「除外リスト」タブ 「制限」タブ 「文字コード変換」タブ
  • 「フィルタ」タブ
  • 「除外リスト」タブ
  • 「制限」タブ
  • 「文字コード変換」タブ
<前(P): プレビュー画面のキー操作 | >次(N): 「フィルタ」タブ | ヘルプの目次(C) | ConcatPrintの説明に戻る


ConcatPrint ヘルプ - 環境設定画面 - 「フィルタ」タブ

環境設定画面 - 「フィルタ」タブ

ファイル選択画面にある「フィルタ」のリスト部分に表示する内容を設定します。よく使う拡張子の組み合わせを登録しておくと便利です。

関連項目: フィルタの指定

<前(P): 環境設定画面 | >次(N): 「除外リスト」タブ | ヘルプの目次(C) | ConcatPrintの説明に戻る


ConcatPrint ヘルプ - 環境設定画面 - 「除外リスト」タブ

環境設定画面 - 「除外リスト」タブ

ここにファイル名を入力しておくと、ファイル一覧を更新した時に自動的にチェックが外れ、印刷対象から除外されます。

※フィルタと違い、セミコロンは使えません。1行に1ファイル名で入力してください。

<前(P): 「フィルタ」タブ | >次(N): 「制限」タブ | ヘルプの目次(C) | ConcatPrintの説明に戻る


ConcatPrint ヘルプ - 環境設定画面 - 「制限」タブ

環境設定画面 - 「制限」タブ

ファイル一覧の表示数

ファイル一覧に表示するファイル数の上限を指定します。 間違って「下位ディレクトリも含める」の状態でルートディレクトリ（C:\\ など）を開いてしまった時に、全ファイルが表示されのを防ぐことができます。

0 を指定した場合は、表示ファイル数の制限は行われません（すべてのファイルが表示されます）。

プレビュー作成

プレビューを最大何ページまで表示するか指定します。（実際に印刷するページ数には影響しません。）

ページ数が非常に多い場合、ページ数の上限を指定することで、プレビュー画面表示までの時間を短縮することができます。

0 を指定した場合、ページ数は制限されません（全ページのプレビューが作成されます）。

<前(P): 「除外リスト」タブ | >次(N): 「文字コード変換」タブ | ヘルプの目次(C) | ConcatPrintの説明に戻る


ConcatPrint ヘルプ - 環境設定画面 - 「文字コード変換」タブ

環境設定画面 - 「文字コード変換」タブ

文字コード変換の設定を行います。

ライブラリ

文字コード変換に使用するライブラリを選択します。

現在選択できるのはjcode.dllだけです（ConcatPrintと同じディレクトリか、WindowsのシステムディレクトリにDLLがインストールされている必要があります）。

「使用しない」を選んだ場合は、文字コードの変換は行われません。

入力文字コード

入力ファイルの文字コードを指定します。選択できる内容は、ライブラリによって変わります。

jcode.dll の場合は、自動判別、JIS、EUC の中から選択できます。

関連項目: jcode.dllについて

<前(P): 「制限」タブ | >次(N): コマンドライン | ヘルプの目次(C) | ConcatPrintの説明に戻る


ConcatPrint ヘルプ - コマンドライン

コマンドライン

コマンドラインからConcatPrintを起動する際の指定方法は次のとおりです。（パラメータはすべて省略可能です。）

ConcatPrint {初期ディレクトリ\フィルタ | 初期ディレクトリ フィルタ;フィルタ;...} { /R | /NR }

初期ディレクトリとフィルタの指定

コマンドラインで、初期表示するディレクトリとフィルタを指定できます。

コマンドラインを次のように指定すると、ディレクトリリストで「C:\Project」が選択された状態になり、フィルタには「*.c」が選択された状態になります。

ConcatPrint C:\Project\*.c

ディレクトリ名とフィルタは、空白で区切って別々に指定することもできます。 フィルタを複数指定する場合は、セミコロン(;)で区切って指定します。

ConcatPrint C:\Project *.c;*.h;*.cpp

ディレクトリ名に空白が含まれる場合は、引用符(")で囲んでください。

ConcatPrint "C:\My Documents\*.txt"

ConcatPrint "C:\My Documents\Projects" *.c;*.h;*.cpp

/R, /NR オプション

「下位ディレクトリも含める」の初期状態を指定します。

/R オプションを指定すると、「下位ディレクトリも含める」がオンになります。

/NR オプションを指定すると、「下位ディレクトリも含める」がオフになります。

<前(P): 「文字コード変換」タブ | >次(N): よくありそうな質問と回答 | ヘルプの目次(C) | ConcatPrintの説明に戻る


ConcatPrint ヘルプ - よくありそうな質問と回答

よくありそうな質問と回答

  • 用紙はどうやって変更するのですか？
  • 1枚に2ページ印刷したいのですが……
  • ネットワーク上のファイルは印刷できませんか？
  • ページ番号の横の「-」は消せませんか？
  • 余白が指定した値より大きくなります
  • 「単位が指定されていません」というエラーが出ます
  • 文字が化けます
  • EUC, JIS, Unicode のファイルは印刷できませんか？
  • プレビューで文字が重なっています
  • プレビューで行番号が左にはみ出ます
  • 行番号が重なって印刷されます
  • ファイルタイトルのフォントは変更できませんか？
  • その他の質問・トラブル

用紙はどうやって変更するのですか？

印刷設定画面から「プリンタの設定」ダイアログを呼び出し、そこで変更できます。

1枚に2ページ印刷したいのですが……

ConcatPrint自体には、1枚の用紙に複数ページ印刷する機能はありません。

「プリンタの設定」ダイアログからプリンタのプロパティを開き、「割り付け」もしくはそれに相当する機能がないか調べてみてください。

ネットワーク上のファイルは印刷できませんか？

ConcatPrintのディレクトリリストではネットワークフォルダを表示できないので、以下のいずれかの方法を使ってください。

ネットワークドライブを使う

  1. メインウィンドウの「ネットワーク」ボタンを押します。
  2. 「ネットワークドライブの割り当て」ダイアログが表示されるので、ネットワークパスを入力して「OK」を押してください。
  3. ドライブリストに先ほど割り当てたドライブが追加されています。後は通常のドライブと同じように操作してください。

ドラッグ＆ドロップで追加する

  1. エクスプローラを起動し、ネットワークフォルダを表示します。
  2. 印刷したいファイルを選択し、ConcatPrintのウィンドウまでドラッグして離します。これでファイル一覧にファイルが追加されます。 ※この方法で追加したファイルは、別のディレクトリを選択したり「フィルタ」を変更すると一覧から消えてしまいます。

ページ番号の横の「-」は消せませんか？

現バージョンでは設定画面は用意されていませんが、iniファイルを編集することでページ番号の書式を変更できます。 次の手順で操作してください。

  1. 一度印刷設定画面を表示し、OKボタンを押して閉じます。（iniファイルを最新の状態にするため）
  2. ConcatPrintを終了させます。
  3. ConcatPrint.exeと同じディレクトリに ConcatPrint.ini というファイルがあるので、適当なエディタで開きます。
  4. ファイルの中に次のような行があります。
    Format.PageNumber="- %d -"

    これを下のように変更します。

    Format.PageNumber="%d"
  5. ファイルを保存して閉じます。

これで、次回起動時からページ番号の書式が変わります。 元の書式に戻すには、同じ手順でiniファイルの内容を元に戻してください。

※ 総ページ数が付いた時の書式を変えるには、同様の手順で Format.TotalPages の値を変更してください。

余白が指定した値より大きくなります

通常、プリンタには印刷可能領域が決まっており、用紙の端までは印刷できません。 ConcatPrintは印刷可能領域内に収まるように余白を調整するので、実際に指定した値より余白が大きくなることがあります。

また、ヘッダやフッタが付く場合、これらを印刷できるように余白を広げるので、本文領域が狭くなる場合があります。

「単位が指定されていません」というエラーが出ます

「余白」や「本文からの距離」は、必ず「1mm」のように単位を付けて指定する必要があります。 使用できる単位については「余白」タブの説明を参照してください。

単位は半角文字で入力してください。全角文字だとエラーになります。

文字が化けます

日本語の文字が化ける場合

フォント設定タブからフォント設定のダイアログを開きます。 このダイアログで、書体の種類が「日本語」になっていることを確認してください。

※ 選択肢に「日本語」がない場合、そのフォントでは日本語を印刷できません。別のフォントを選んでください。

日本語フォントを選んでもまだ文字化けする場合→EUC, JIS, Unicode のファイルは印刷できませんか？

「・」や「■」などの変な記号が印刷される

ファイルに制御コード（0x00～0x1Fの文字）が入っている可能性があります。

ConcatPrintは、タブ(0x09)、復帰(0x0A)、改行(0x0D)以外はそのまま印字します。通常のフォントには制御コードに対応する文字がないため、「・」のような記号で印刷されてしまいます。 お手数ですがファイルを編集して、不要な制御コードを取り除いてから印刷してください。

EUC, JIS, Unicode のファイルは印刷できませんか？

EUC, JIS のファイルは、同梱のライブラリで文字コードを変換して印刷できます。 [環境設定]-[文字コード変換] から設定を行ってください。

Unicodeについては未対応です。あらかじめ Shift JIS に変換してから印刷するようにしてください。

プレビューで文字が重なっています

プリンタフォントを選択した場合に、このような現象が起きることがあります。

フォント選択画面で、フォント名の横に下のようなアイコンが表示されるのはプリンタフォントです。

このようなフォントを使った場合、プレビューでは画面に表示できるフォントで代用するため、レイアウトが崩れて見えることがあります。 実際の紙面では正常に印刷されるので問題ありません。

プレビューで行番号が左にはみ出ます

プレビューで文字が重なるのと同じ現象です。

プリンタフォントを選択した時にこのような現象が起きることがありますが、プレビュー画面上でずれるだけで、実際の紙面では正常に印刷されます。

行番号が重なって印刷されます

ConcatPrintは本文フォントのサイズを元にして行間を計算するので、行番号のフォントが本文より大きいと、文字が重なってしまいます。

フォントの設定で行番号のフォントを小さくするか、 体裁の設定で行間スペースを広げてください。

ファイルタイトルのフォントは変更できませんか？

現バージョンでは変更できません。本文と同じフォントで印刷されます。

その他の質問・トラブル

このヘルプで解決できない質問や不具合については、 サポートページ内の掲示板へお寄せください。 その際には、できるだけ以下の情報を記載するようにお願いします。

  • ConcatPrintのバージョン（[ヘルプ]-[バージョン情報]で確認できます）
  • 使用しているOSのバージョン（例: Windows 2000 Professional）
  • 質問・不具合の内容をできるだけ詳しく
<前(P): コマンドライン | ヘルプの目次(C) | ConcatPrintの説明に戻る